Join us on Children of Ur, while we wait!

Hello again! Good to see so many familiar names in the Forums after all these years :)

I'd love to populate the streets of CoU (https://childrenofur.com/game/ if you aren't familiar yet) while we wait for the Eleven server load to get stronger; it's been so fun seeing old Glitchen popping up in the world over the past few weeks. Come hang out!

Comments

  • Just been on , and I'm invisible! fun, but a bit inconvenient
  • I registered with CoU ages ago but then was alpha-testing Eleven, I have revived my character and played a bit, though I don't have much time I am afraid. CoU takes some getting used to but it is fun, everyone should try it!
  • I did play CoU for a bit before I became an alpha tester chrome was not working so I used firefox there was no one there it was very lonely I did manage to get one of my friend to play with me and we were online just letting ya know but it was a great replacement of glitch
  • CoU is working on Chrome now. Just to let people know.
  • oh that explains a bit
  • Needing some Tree scaping. Several of the trees are at the dead cycle ( Undermine Hollows particularly)but not re-plantable by players. Is there a way to have a Horticulturist pop in and redo the dying:) It's lonely over here:):)
  • For some reason it doesn't work for me at all.
  • Nor for me any more, I have tried everything suggested but nothing works. :(
  • edited June 1
    Since the announcement of the merge I have been trying to log into the game with this url:
    https://childrenofur.com/game/ I posted on fb page I couldn't login and one of the devos posted Chrome was now working. I sent a message to the devo who posted but have not received a reply as to suggestions to load the game. I have been able to log into the game in the past with the Children of Ur url but not any more.

    I have unisntalled Chrome, tired to load on Microsoft Edge, installed Mozilla. The game will open on all 3 to the screen with the "turning world". The page loads just for a split second before the main screen opens I get a page saying "if you see this message for more than 10 sec you browers isn't supporting the game".

    The login page has the turning world with the message in the bottom left "chatting with server"
    When I enter the emai and password it will not load. I have tried signing in with fb and also resetting my password.

    I was able to play the game prior to the announcement of the merge. I guess I am out of luck. My only hope is when Eleven goes into open beta I will be able to load the game.

    Several people posted on fb some things to try but nothing I try works. It is reassuring others are having the same problems as me.

    :(
  • @BoxySister I thought of one other thing that might help, maybe sign in with facebook, which I never do for anything else, but I have a ton of blockers on chrome and I can still log in.
  • Tried signing in with facebook too, just get a never ending spinning world with "hello there" in the middle, never loads...
  • For the last month nothing I have done previously will get back in game. Sadly I am froze out. I check back in regularly with various browsers and private windows,etc. hopin something works. Not to be done......
  • I was able to get in to CoU until recently. Now I get a an endless loop of the loading music (and loading screen obscured by a semitransparent screen) with the message "Oh dear! Looks like the server is down. Please try again later." No matter when I try I get the same message. Hopefully I'll probably get in "soon"...
  • The same thing happens to me too. It sometimes comes online for a little bit, but you get stuck on the same street before it crashes again.
  • Doesn't seem like the pw/sign up field goes anywhere. I peeped the code and something is not right.
  • Hopefully Eleven opens up soon, it seems like they are pretty far ahead of Children of Ur.
Sign In or Register to comment.